[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] TAB key does not let me insert a non-existing label

From: Ralf Angeli
Subject: Re: [Bug-AUCTeX] TAB key does not let me insert a non-existing label
Date: Tue, 14 Sep 2010 20:15:43 +0200

* Scot Becker (2010-09-14) writes:

> Thanks for the reply.  I tried it now on both Emacs 23 and 24, with
> both my full setup and with emacs -Q, with identical results.  When
> you tried it, did you test it by typing a citation key that is not in
> your database?

Oohh, sorry I failed to get this piece of information from your original
message.  So I tried it with an existing entry.  My bad.

> It works fine if I only use keys in my database, but
> not if I type one that isn't there.

Okay, I can reproduce this now.  The flashing in the echo area you see
is actually an error which is thrown deliberately.  Carsten added the
piece of code which does this in 2005 to reftex-cite.el.  I'm not sure
why because after that statement there has still been some code which
deals with non-existent keys.  It just needed a bit of tweaking to work
again.  So I've now reinstated the functionality as advertised in the
manual and hope I did not break too much in course of that.  At least
for the cases I've tested it with, it worked.

>> A common workaround is to copy the text generated by `reftex-report-bug'
>> into a message to be sent through a configured mail client.
> Somehow an appropriately broken mail setup throws up an error even
> before any text is generated by `reftex-report-bug'.  I can remove the
> setup if it would help us debug, but the above recipe is with emacs
> -Q, so I guess it's not needed.

Likely not.  Strange.  In my case it works (also with emacs -Q), so it
could be an Emacs bug.  Eventually I should update my installation to
get the new bugs, too ...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]