[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-AUCTeX] csquotes-options doesn't take precedence over language-

From: Anders Johansson
Subject: Re: [Bug-AUCTeX] csquotes-options doesn't take precedence over language-specific ones
Date: Sun, 20 Mar 2011 19:00:08 +0100
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110223 Lightning/1.0b2 Thunderbird/3.1.8

2011-03-20 18:01, Ralf Angeli skrev:
* Anders Johansson (2011-03-14) writes:

I use the package csquotes and tried to use the options:
LaTeX-csquotes-open-quote, LaTeX-csquotes-close-quote.

I followed the instructions here:

Nothing changed as I changed the values of LaTeX-csquotes-open-quote and
LaTeX-csquotes-close-quote, but than I realized that it worked if I
didn't use babel (I was writing in Swedish).

Hence it looks like the language-specific quote characters take
precedence over the csquotes ones. Not what's expected and not what is
stated in the manual:
This is working fine here with development versions of Emacs and AUCTeX
and the following sample file:


%%% Local Variables:
%%% mode: latex
%%% TeX-master: t
%%% End:

The variables are set through Customize, hence the following settings
are found in the init file:

  '(LaTeX-csquotes-close-quote "«")
  '(LaTeX-csquotes-open-quote "»")

After opening the above file, `C-h v TeX-quote-language<RET>' results
in the following:

TeX-quote-language is a variable defined in `tex.el'.
Its value is (override "»" "«" nil)

What's the result in your case if you do this with the sample file
opened?  You might have to type `C-c C-n' before in order to force the
file to be parsed.

Emacs : GNU Emacs 23.1.1 (i686-pc-linux-gnu, GTK+ Version 2.22.0)
of 2010-11-26 on vernadsky, modified by Debian
Package: 11.86
Is this the package provided by Debian?

It all worked with the sample file. I stripped down the file that I had a problem with and found out that it would only work if I loaded babel after csquotes (as is the case in the sample file). I don't know if this is the expected behaviour but it sort of goes against the recommendation in wikibooks "You should place it soon after the \documentclass command, so that all the other packages you load afterwards will know the language you are using." (http://en.wikibooks.org/wiki/LaTeX/Internationalization ; about babel).

Well I guess the problem is solved then.

Emacs package from Ubuntu repositories, auctex downloaded from website.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]