[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#20320: 11.88.3; AUCTeX, ESS, Noweb, and "Error running timer `font-l

From: Bourgoin, Mario
Subject: bug#20320: 11.88.3; AUCTeX, ESS, Noweb, and "Error running timer `font-latex-jit-lock-force-redisplay': (wrong-number-of-arguments (2 . 2) 3)" SOLVED
Date: Mon, 13 Apr 2015 20:49:11 +0000

In digging deeper into the problem to answer questions by Tassilo Horn,  I resolved the problem as due to running


I noticed that the AUCTeX file `font-latex.el' whence the function ` font-latex-jit-lock-force-redisplay’ came was the one installed with my Emacs even though I had updated AUCTeX to 11.48.3. The reason for this problem was that the path to this file was earlier on my load path than the path to the AUCTeX installed later. The reason for that problem was that I installed the MELPA repository by following the instructions at




which required that I run ``(package-initialize)’’ in my Emacs initialization file. Doing so apparently pushes the old AUCTeX path on the load-path. This is not a side effect of running `package-initialize’ after Emacs startup.


Resolution: Don’t do that (i.e. run ‘package-initialize’ in the Emacs initialization file).

Additionally: Since `package-archives’ is a customizable variable, add to it the MELPA package using the custom system.


Mario Bourgoin

Senior Data Scientist – Hopkinton

EMC CTD Symmetrix uCode

(508) 249-1297 Direct


From: Bourgoin, Mario
Sent: Friday, April 10, 2015 1:14 PM
To: 'address@hidden'
Subject: 11.88.3; AUCTeX, ESS, Noweb, and "Error running timer `font-latex-jit-lock-force-redisplay': (wrong-number-of-arguments (2 . 2) 3)"


Remember to cover the basics, that is, what you expected to happen and

what in fact did happen.


Be sure to consult the FAQ section in the manual before submitting

a bug report.  In addition check if the bug is reproducable with an

up-to-date version of AUCTeX.  So please upgrade to the version

available from http://www.gnu.org/software/auctex/ if your

installation is older than the one available from the web site.


If the bug is triggered by a specific (La)TeX file, you should try

to produce a minimal sample file showing the problem and include it

in your report.


Your bug report will be posted to the AUCTeX bug reporting list.



The effect is to generate the error message:

  Error running timer `font-latex-jit-lock-force-redisplay': (wrong-number-of-arguments (2 . 2) 3)

or drop into the debugger with debug-on-error set to t.


Contents of file foo.Rnw:




%%% Local Variables:

%%% eval: (ess-noweb-mode t)

%%% End:



Position the cursor anywhere in the file.

Run the command "LaTeX-section".

Type a level or no level at all, and press enter.

Type a title or no title at all, and press enter.


Note: The "Rnw" file type makes the major mode be LaTeX and adds the polymode for Rnw minor mode.  The motivation for turning on the ess-noweb-mode minor mode is to obtain the default bindings for knitr-ing and then pdflatex-ing the document.


Emacs  : GNU Emacs 24.4.1 (i686-pc-mingw32)

of 2014-10-24 on LEG570

Package: 11.88.3


current state:



AUCTeX-date "2015-03-22"

window-system 'w32

LaTeX-version "2e"

TeX-style-path '("~/.emacs.d/auctex" "c:/Users/bourgm1/.emacs.d/elpa/auctex-11.88.3/style"

                                  "c:/Users/bourgm1/.emacs.d/auctex/auto" "c:/Users/bourgm1/.emacs.d/auctex/style" "auto" "style")

TeX-auto-save nil

TeX-parse-self nil

TeX-master t

TeX-command-list '(("TeX" "%(PDF)%(tex) %`%S%(PDFout)%(mode)%' %t" TeX-run-TeX nil

                                     (plain-tex-mode ams-tex-mode texinfo-mode) :help "Run plain TeX")

                                    ("LaTeX" "%`%l%(mode)%' %t" TeX-run-TeX nil (latex-mode doctex-mode) :help "Run LaTeX")

                                    ("Makeinfo" "makeinfo %t" TeX-run-compile nil (texinfo-mode) :help

                                     "Run Makeinfo with Info output")

                                    ("Makeinfo HTML" "makeinfo --html %t" TeX-run-compile nil (texinfo-mode) :help

                                     "Run Makeinfo with HTML output")

                                    ("AmSTeX" "%(PDF)amstex %`%S%(PDFout)%(mode)%' %t" TeX-run-TeX nil (ams-tex-mode) :help

                                     "Run AMSTeX")

                                    ("ConTeXt" "texexec --once --texutil %(execopts)%t" TeX-run-TeX nil (context-mode) :help

                                     "Run ConTeXt once")

                                    ("ConTeXt Full" "texexec %(execopts)%t" TeX-run-TeX nil (context-mode) :help

                                     "Run ConTeXt until completion")

                                    ("BibTeX" "bibtex %s" TeX-run-BibTeX nil t :help "Run BibTeX")

                                    ("Biber" "biber %s" TeX-run-Biber nil t :help "Run Biber")

                                    ("View" "%V" TeX-run-discard-or-function t t :help "Run Viewer")

                                    ("Print" "%p" TeX-run-command t t :help "Print the file")

                                    ("Queue" "%q" TeX-run-background nil t :help "View the printer queue" :visible


                                    ("File" "%(o?)dvips %d -o %f " TeX-run-command t t :help "Generate PostScript file")

                                    ("Index" "makeindex %s" TeX-run-command nil t :help "Create index file")

                                    ("Check" "lacheck %s" TeX-run-compile nil (latex-mode) :help

                                     "Check LaTeX file for correctness")

                                    ("Spell" "(TeX-ispell-document \"\")" TeX-run-function nil t :help "Spell-check the document")

                                    ("Clean" "TeX-clean" TeX-run-function nil t :help "Delete generated intermediate files")

                                    ("Clean All" "(TeX-clean t)" TeX-run-function nil t :help

                                     "Delete generated intermediate and output files")

                                    ("Other" "" TeX-run-command t t :help "Run an arbitrary command"))



reply via email to

[Prev in Thread] Current Thread [Next in Thread]