[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35310: 11.91; AUCTeX/Evince: server does not start, poor direct sear

From: Cédric Martínez Campos
Subject: bug#35310: 11.91; AUCTeX/Evince: server does not start, poor direct search, inverse search does not work
Date: Sun, 21 Apr 2019 17:36:37 -0500

Hi Ikumi,

thank you for your interest. Indeed it is something D-Bus related. I
was using a script I found many years ago on the web but it stopped
working. I therefore changed to another script,
https://gist.github.com/dandrake/2297447, which didn't work either. It
gives me the following error:

D-Bus error: "Unit org.gnome.Evince.service not found."

I then saw that Emacs/AUCTeX has currently built-in direct/inverse
search, which I tried and, as I mentioned, neither works (for me).

Coming back to your questions, these are the outputs I get when I
issue the commands you suggested.

Just after launching Emacs.

(featurep 'dbusbind) C-x C-e
(TeX-evince-dbus-p "gnome" "evince") C-x C-e
Debugger entered--Lisp error: (void-function TeX-evince-dbus-p)
  (TeX-evince-dbus-p "gnome" "evince")
  eval((TeX-evince-dbus-p "gnome" "evince") nil)
  funcall-interactively(eval-last-sexp nil)
  call-interactively(eval-last-sexp nil nil)

Just after opening a .tex file.

(featurep 'dbusbind) C-x C-e
(TeX-evince-dbus-p "gnome" "evince") C-x C-e

I have tried to install emacs26 and auctex12, with no success.

With respect to the term "server", I don't know exactly who runs the
server. As far as I know, Emacs initiates a particular "evinced"
instance, which is a server for Evince,
Isn't it?

I appreciate much the help.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]