[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#35614: AUCTeX stopped working after upgrade: TeX-shdex-eval: Invalid

From: Jakub Narębski
Subject: bug#35614: AUCTeX stopped working after upgrade: TeX-shdex-eval: Invalid dialect expression : :classopt.
Date: Fri, 10 May 2019 10:42:48 +0200

On Thu, 9 May 2019 at 11:06, Ikumi Keita <address@hidden> wrote:
> Hi Jakub,
>>>>>> Jakub Narębski <address@hidden> writes:
>> After upgrading AUCTeX using ELPA to version 12.1.2 it stopped working
>> with the following error (after trying to turn on the latex-mode):
>>   TeX-shdex-eval: Invalid dialect expression : :classopt.

Thankfully I use version of GNU Emacs with AUCTeX preinstalled,
so uninstalling ELPA version made AUCTeX work as workaround
(AUCTeX-date "2017-06-03", from

> It seems that you are using unupdated tex.el or tex.elc.  The
> possibilities I can think of now are:
> (1) Updating from ELPA is not complete for some reason, or

Possible, as at the time of bug I have had both 12.1.2 and 12.1.1
marked as installed in the list of packages, the second one marked
as obsolete.

> (2) In somewhere in the load-path of your emacs, stale version of
> tex.el or tex.elc (or both) is left behind and used instead of the
> updated one(s), or
> (3) The elisp variable `TeX-style-hook-dialect-weight-alist' is
> overwritten for some reason.
> Can you first try updating from ELPA again?

It worked after installing package from ELPA (maybe).
Unfortunately the error persists (after restarting Emacs), this time as

  File mode specification error: (error Invalid dialect expression : :classopt.)
  File local-variables error: (error Invalid dialect expression : :classopt.)
when loading file, and

  TeX-shdex-eval: Invalid dialect expression : :classopt.

after `M-x LaTeX-mode`.

Font lock works, for some strange reason.

>                                                                         If 
> that doesn't resolve the
> problem, please include the output of M-x TeX-submit-bug-report in your
> reply.

There was problem with that idea, as `M-x TeX-submit-bug-report` didn't
work either with the same problem (but in different command).  Now it works:

Emacs  : GNU Emacs 25.2.1 (x86_64-w64-mingw32)
 of 2017-04-24
Package: 2017-06-03

current state:
 AUCTeX-date "2017-06-03"
 window-system 'w32
 LaTeX-version "2e"
 TeX-style-path '("c:/emacs-modified-windows/tmpdir/emacs/var/auctex"
  "c:/Program Files/GNU Emacs 25.2/share/emacs/site-lisp/auctex/style"
  "c:/Users/jnare/.emacs.d/auctex/auto" "c:/Users/jnare/.emacs.d/auctex/style"
  "auto" "style")
 TeX-auto-save nil
 TeX-parse-self nil
 TeX-master t
 TeX-command-list '(("TeX"
     "%(PDF)%(tex) %(file-line-error) %(extraopts) %`%S%(PDFout)%(mode)%' %t"
     TeX-run-TeX nil (plain-tex-mode ams-tex-mode texinfo-mode) :help
     "Run plain TeX")
    ("LaTeX" "%`%l%(mode)%' %t" TeX-run-TeX nil (latex-mode doctex-mode) :help
     "Run LaTeX")
    ("Makeinfo" "makeinfo %(extraopts) %t" TeX-run-compile nil (texinfo-mode)
     :help "Run Makeinfo with Info output")
    ("Makeinfo HTML" "makeinfo %(extraopts) --html %t" TeX-run-compile nil
     (texinfo-mode) :help "Run Makeinfo with HTML output")
    ("AmSTeX" "amstex %(PDFout) %(extraopts) %`%S%(mode)%' %t" TeX-run-TeX nil
     (ams-tex-mode) :help "Run AMSTeX")
    ("ConTeXt" "%(cntxcom) --once --texutil %(extraopts) %(execopts)%t"
     TeX-run-TeX nil (context-mode) :help "Run ConTeXt once")
    ("ConTeXt Full" "%(cntxcom) %(extraopts) %(execopts)%t" TeX-run-TeX nil
     (context-mode) :help "Run ConTeXt until completion")
    ("BibTeX" "bibtex %s" TeX-run-BibTeX nil t :help "Run BibTeX")
    ("Biber" "biber %s" TeX-run-Biber nil t :help "Run Biber")
    ("View" "%V" TeX-run-discard-or-function t t :help "Run Viewer")
    ("Print" "%p" TeX-run-command t t :help "Print the file")
    ("Queue" "%q" TeX-run-background nil t :help "View the printer queue"
     :visible TeX-queue-command)
    ("File" "%(o?)dvips %d -o %f " TeX-run-dvips t t :help
     "Generate PostScript file")
    ("Dvips" "%(o?)dvips %d -o %f " TeX-run-dvips nil t :help
     "Convert DVI file to PostScript")
    ("Dvipdfmx" "dvipdfmx %d" TeX-run-dvipdfmx nil t :help
     "Convert DVI file to PDF with dvipdfmx")
    ("Ps2pdf" "ps2pdf %f" TeX-run-ps2pdf nil t :help
     "Convert PostScript file to PDF")
    ("Index" "makeindex %s" TeX-run-index nil t :help
     "Run makeindex to create index file")
    ("Xindy" "texindy %s" TeX-run-command nil t :help
     "Run xindy to create index file")
    ("Check" "lacheck %s" TeX-run-compile nil (latex-mode) :help
     "Check LaTeX file for correctness")
    ("ChkTeX" "chktex -v6 %s" TeX-run-compile nil (latex-mode) :help
     "Check LaTeX file for common mistakes")
    ("Spell" "(TeX-ispell-document \"\")" TeX-run-function nil t :help
     "Spell-check the document")
    ("Clean" "TeX-clean" TeX-run-function nil t :help
     "Delete generated intermediate files")
    ("Clean All" "(TeX-clean t)" TeX-run-function nil t :help
     "Delete generated intermediate and output files")
    ("Other" "" TeX-run-command t t :help "Run an arbitrary command"))

Jakub Narebski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]