[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37719: 11.91; preview-latex not working (again?)

From: Ikumi Keita
Subject: bug#37719: 11.91; preview-latex not working (again?)
Date: Mon, 14 Oct 2019 02:34:03 +0900

Hi Dylan,

>>>>> Dylan Thurston <address@hidden> writes:
> Preview-latex is still not working; the error message (on the same
> minimal file) is now as follows:

Thank you for a valuable report.  It seems that the Ghostscript
developers injected some change incompatible with preview-latex into gs
source, and that change was incorporated into the ghostscript binary
distribution of your package manager (Debian?).  I tried both gs 9.28
RC4 and the latest git repository, and ended up with the same result of

| /home/keita/gs/bin/gs -dOutputFile\=\(bbb.prv/tmp0UabeI/pr1-1.png\) -q 
-dDELAYSAFER -dNOPAUSE -DNOPLATFONTS -dPrinted -dTextAlphaBits\=4 
-dGraphicsAlphaBits\=4 -sDEVICE\=png16m -r108.606x108.587 -dDELAYBIND
| GS>{<</PermitFileReading[(bbb.pdf)(bbb.prv/tmp0UabeI/preview.dsc)]>> 
setuserparams .locksafe} stopped pop {DELAYSAFER{.setsafe}if}stopped 
pop/.preview-BP currentpagedevice/BeginPage get dup null eq{pop{pop}bind}if 
def<</BeginPage{currentpagedevice/PageSize get dup 0 get 1 ne exch 1 get 1 ne 
or{.preview-BP gsave 1 1 0.878431 setrgbcolor clippath fill grestore 
}{pop}ifelse}bind/PageSize[1 1]>>setpagedevice/preview-do{/.preview-ST[count 4 
roll save]def dup length 0 eq{pop}{setpagedevice}{ifelse 
exec}stopped{handleerror quit}if .preview-ST aload pop restore}bind def  
(bbb.prv/tmp0UabeI/preview.dsc)(r)file /.preview-ST 1 index def dup 0 
setfileposition 407()/SubFileDecode filter cvx exec .preview-ST dup dup 407 
setfileposition 51()/SubFileDecode filter cvx<<>>preview-do
| Error: /invalidfileaccess in --file--
| Operand stack:
|    (bbb.prv/tmp0UabeI/preview.dsc)   (r)
| Execution stack:
|    %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--   
%loop_continue   --nostringval--   --nostringval--   false   1   %stopped_push  
 .runexec2   --nostringval--   --nostringval--   --nostringval--   2   
%stopped_push   --nostringval--
| Dictionary stack:
|    --dict:1175/1684(ro)(G)--   --dict:0/20(G)--   --dict:78/200(L)--
| Current allocation mode is local
| Last OS error: Permission denied
| Current file position is 606
| GS<2>

I have no workaround for this trouble now.  Please consider reverting
the recent gs update if you can.

I'll report this issue to gs-devel list.

Ikumi Keita

reply via email to

[Prev in Thread] Current Thread [Next in Thread]