bug-auctex
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#54099: 13.1.0; Company mode throws error when type "\lab" in a latex


From: 吴锐扬
Subject: bug#54099: 13.1.0; Company mode throws error when type "\lab" in a latex buffer
Date: Wed, 23 Feb 2022 00:28:32 -0700

Hi Tassilo,

It works now. Thanks for the quick fix.

Best,
Ruiyang


> On Feb 22, 2022, at 7:38 AM, Tassilo Horn <tsdh@gnu.org> wrote:
> 
> 吴锐扬 <ywwry66@gmail.com> writes:
> 
>> As the title suggests, when working in a latex buffer, if I type
>> something starting with a backslash which has possible completions,
>> such as "\lab", "\mak" "\tex", company mode will throw an error. The
>> error trace back is as follows:
>> 
>>> Debugger entered--Lisp error: (wrong-type-argument stringp (lambda nil
>>> (interactive) (insert "\\parens*{") (push-mark) (insert "}")
>>> (exchange-point-and-mark)))
>> 
>> The first line in the output above is because I have the following code
>> in my init.el file:
>> (setq LaTeX-math-list '(("C-9" (lambda () (interactive) (insert 
>> "\\parens*{") (push-mark) (insert "}") (exchange-point-and-mark)) nil nil)))
>> 
>> The problem seems to be the new function
>> LaTeX--completion-annotation-from-math-menu does not like the
>> anonymous function in LaTeX-math-list. Is this a bug or should I just
>> use named functions in LaTeX-math-list?
> 
> It's a bug which I've hopefully fixed right now.  I'll make a new ELPA
> release ASAP.  Please report back if it works then.
> 
> Bye,
> Tassilo






reply via email to

[Prev in Thread] Current Thread [Next in Thread]