bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bash problems with gvim and tightVNC??


From: f
Subject: bash problems with gvim and tightVNC??
Date: 9 Dec 2001 20:09:49 -0800

I'm not sure if this detail is relevant to the following problem or
not, but
I didn't mention that our solaris 8 machines (which runs the server,
or
should if it wasn't for this problem) are set up to run bash as the
default.
The reason why I suspect this as a possible cause is that even my gvim
startup script gets improperly interpretted when I invoke the
executable
from a different account from which it was built (gvim gets choked by
starting a continued line with "\ ", which is suppose to be how lines
are
made to continue on.

The "make" for both gvim and tightvnc was done
after i explicitly switched to tcsh via "exec tcsh".  However, the
problem
manifest itself when I invoke the executable (gvim or vncserver) from
another account, regardless of whether I "exec tcsh" or stay in bash.
I even went so far as to put a tcsh script wrapper around the
executable,
then tried a bash wrapper.  The problem still persists.

One odd clue from the bash wrapper(which is the only one I spent time
trouble-shooting) is that the path from ".bashrc" gets lost, even
though the
.bashrc is invoked (I confirmed it by printing out a diagnostic
message
within .bashrc).  Weird, huh?  To get around this, I put "source
~/.bashrc"
into the wrapper.  But it does indicate there is some funny business
going
on that I'm not understanding.  I added a print command to the invoked
perl
script that starts tightVNC and confirmed that the PATH was in fact
being properly retained.  Also, the text of the vnc error message
doesn't appear
within the perl script, so it must be issued by the Xvnc binary that
it
invokes.  So the baffling thing is that it passes the sanity checks in
the
"vncserver" perl script, including test for proper creation of .vnc,
but
then can't find it from the invoked binary.

Thanks for any tidbits of wisdom....

P.S.  I am currently unable to send to mailing lists and newsgroups at
the
same time, and I've also separately mailed to

     address@hidden,
address@hidden

Please copy any responses to those groups so that the information
in the thread can be consistent across all those forums.  Thanks!
--------------------------------------------------------------------------
Fred Ma
Department of Electronics
Carleton University, Mackenzie Building
1125 Colonel By Drive
Ottawa, Ontario
Canada     K1S 5B6
address@hidden
==========================================================================

"Shing-Fat (Fred) Ma" wrote:

> Hi,
>
> I just installed tightVNC and got it working.  It's awesome.
>
> I tried to show somebody else how awesome it was.
> I tried to run vncserver from his account (the installation
> was made in my personal account space, and all files/directories
> are publically accessible; all files in the bin directory are
> publicly executable).  So from the account of PersonB,
> I was in the directory /home/PersonB, I issued:
>
>      /home/PersonA/INSTROOT/bin/vncserver -nolisten local
>
> I get the error
>
>      vncserver: "~/.vnc: No such file or directory"
>
> I create the directory ~/.vnc in his home directory, but this
> message still persists.
>
> Is there anything special I have to do to make my installation
> executable by others?  It would be such a waste if only I
> could use it....
>
> Thanks.
>
> Fred
>
> --------------------------------------------------------------------------
> Fred Ma
> Department of Electronics
> Carleton University, Mackenzie Building
> 1125 Colonel By Drive
> Ottawa, Ontario
> Canada     K1S 5B6
> address@hidden
> ==========================================================================



reply via email to

[Prev in Thread] Current Thread [Next in Thread]