bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bash 2.05b.0(1) compile error on HP-UX B.11.00 cc


From: Chet Ramey
Subject: Re: Bash 2.05b.0(1) compile error on HP-UX B.11.00 cc
Date: Mon, 7 Oct 2002 09:23:27 -0400

> Bash Version:   GNU bash, version 2.05b.0(1)-release (hppa1.1-hp-hpux11.00)
> OS/Hardware:    HP-UX B.11.00 A 9000/811
> Compiler:       HP-UX POSIX-conforming C compiler (cc)
> Description:
> 
>         cc -c  -DHAVE_CONFIG_H -DSHELL   -I. -I..  -I.. -I../include 
> -I../lib -I. -DHPUX   -g shopt.c || ( rm -f shopt.c ; exit 1 )
>         rm -f shopt.c
>         rm -f printf.o
>         ./mkbuiltins -D . printf.def
>         cc -c  -DHAVE_CONFIG_H -DSHELL   -I. -I..  -I.. -I../include 
> -I../lib -I. -DHPUX   -g printf.c || ( rm -f printf.c ; exit 1 )
> cc: "printf.def", line 824: error 1718: Types are not assignment-compatible.
> *** Error exit code 1

HP/UX 11.x has horribly broken `long double' support.  Try editing
config.h to remove the HAVE_LONG_DOUBLE and HAVE_STRTOLD defines, and
rebuilding.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
( ``Discere est Dolere'' -- chet )

Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]