[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bash prompt issue - lenny - UTF-8.

From: Chris Jones
Subject: Re: bash prompt issue - lenny - UTF-8.
Date: Tue, 30 Jun 2009 21:04:21 -0400
User-agent: Mutt/1.5.18 (2008-05-17)

On Tue, Jun 30, 2009 at 01:34:21PM EDT, Chet Ramey wrote:
> Chris Jones wrote:


> > Is there anything that happened between 3.2.39 & 3.2.49 that might
> > account for this, or would you suspect a problem with my setup?
> I would assume that one of the patches addresses this problem.

It's either my setup that's causing this or the fix came into existence
between 3.2.48 and 3.2.49:

I have tested on the current up-to-date ubuntu system that runs the
former and I recreated the problem.

Back with 3.2.39 on the lenny sustem, I ran the same test in the linux
console and witnessed the same behavior as in xterm.

I proceeded to switch my default locale to en_US.iso88591 and this fixed
the problem both on the linux console and xterm.

I switched back to en_US.utf8 and was able to recreate the problem.

> > Or should I run a test with a more current version of bash and if I
> > can't recreate, forget about it?
> You should always test against the most current version.  In your
> case, you can test against more recent versions of bash-3.2 or
> bash-4.0.  If the work to fix the problem has already been done and
> released, why not take advantage of it?

I'll run a test with 3.2.49 just in case, if time allows.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]