[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Calling Bash with /S

From: sweinberger
Subject: Calling Bash with /S
Date: Wed, 22 Jun 2011 09:59:45 -0700 (PDT)

Hi All,

I am calling bash from dmake.  The make file initiates the call to bash as

/bin/bash /S /c ""

The command to execute is between the double quotes.  For instance

In Make File:
@ls -l ./SomeDir/*

Bash Command
/bin/bash /S /c "ls -l ./SomeDir/*"

The /S from what I see enables regular expression processing in the bash
command line, but maybe I might be wrong.  In any event, the problem that I
have is the asterisk.  Bash does not like it.  I tried escaping it with a
backslash up to nine levels but that did not work; should only require one.

Yes, the actual command that I use is not ls.  In the real example, I am
using "rm -f", but ls is a good example too and safer for experimentation.

How do I write the command line, so that it works?  "ls -l ./SomeDir/\*"
does not work, nor anything else that I tried so far.

Thanks in advance,

View this message in context: 
Sent from the Gnu - Bash mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]