[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem inserting Unicode heavy minus sign (U+2796)

From: Linda Walsh
Subject: Problem inserting Unicode heavy minus sign (U+2796)
Date: Thu, 27 Jun 2013 22:43:10 -0700
User-agent: Thunderbird

Have an oddity in bash.

Tried to insert the heavy minus sign and I get deterministic garbage:

echo "^K$"|hexdump
0000000 9ee2 0b01 0a24 vs. if I use 'cat', or just raw input to hexdump:

➖0000000 9ee2 0096 0000003

(that minus sign before the first line is me typing in the
char followed by a few control-d's

Coincidentally, E29E96 is the UTF-8 encoding of that character...so
it seems like my system can send the 'right stuff'...
(tried in SecureCRT & xfce_terminal -- same result).

Note U+2795 (heavy plus) and U+2797 (heavy divide) work fine!

Is there any easy way to get readline to dump it's settings?

set convert-meta off
set input-meta on
set meta-flag on
set output-meta on

I think the above are the pertinent .inputrc settings (?)...

stty shows: -ignpar -parenb -parodd cs8 [-]iutf8

-- the last one was -iutf8, which seemed odd, so I tried iutf8... makes
no difference?  weird.  Should it?

Since it works for most other chars, there must be some confusion for that 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]