[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ls doesn't work in if statements in bash 4.3

From: Chris Down
Subject: Re: ls doesn't work in if statements in bash 4.3
Date: Fri, 28 Mar 2014 10:23:17 +0800
User-agent: Mutt/1.5.23 (2014-03-12)

address@hidden writes:
> > huge wall of text

First of all, please follow basic etiquette and trim your quotes to what
is relevant. I can't even fit your e-mail on my entire screen.

> On one hand I realize you think you're being helpful to someone who
> has just started bash programming, but since I've been at this for 
> 12 years it has gotten a little condescending.  I solved the issue
> myself about 10 minutes later.  I thought it was interesting that with
> the problematic dir_colors file I was unable to use 'ls' but 'find'
> worked.  I work as a system administrator so I understand that people
> are at different levels in terms of technical knowledge.  It's all
> about reading comprehension.  If you had read "My filenames never have
> spaces" part and actually paid attention you would see that the
> problem had nothing to do with spaces.  But no.  Everyone wants to
> show how smart they are that spaces can mess things up.  Wow!  Thanks!
> My guess is that you'll breeze right past this post and continue to
> give me helpful hints.  Thanks guys!

There is only one thing that is worse than a person that doesn't take
advice and continues to ask regardless: the one that seeks advice,
attacks those that try to help, and then in a fit of embarassment
provides a perilously long, rambling e-mail to claim that they "knew it
all along".

Show some respect to the people on this list and don't post here if
you're going to act in such a manner. It's simply disrespectful and

Attachment: pgpnOuo3XbwvF.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]