bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot build bash-4.2 with Patch 53


From: TODD TRIMMER
Subject: Re: Cannot build bash-4.2 with Patch 53
Date: Fri, 10 Oct 2014 13:02:17 -0500

You're right. The y.tab.[ch] files never got rebuilt. They still had the
same timestamps from the base archive of 4.2. Renaming them forced a
rebuild, which had significant diffs. Is there a flag that can be sent to
configure or make to force a rebuild? BTW, bison was already installed.

On Thu, Oct 9, 2014 at 11:47 PM, Steve Simmons <address@hidden> wrote:

>
> On Oct 9, 2014, at 9:34 PM, TODD TRIMMER <address@hidden> wrote:
>
> > If I compile from bash-4.2 from source, cumulatively applying patches
> through 52, things work fine. If I start from scratch and apply through 53,
> it errors out:
> >
> > gcc -L.. . .
> > ./builtins/libbuiltins.a(evalstring.o): In function `parse_and_execute':
> > /home/ttrimmer/depot/ext/bash/patch/src/builtins/evalstring.c:274:
> undefined reference to `parser_remaining_input'
> > collect2: ld returned 1 exit status
> > make: *** [bash] Error 1
> >
> >
> > I can see parser_remaining_input patched in parse.y and
> builtins/evalstring.c. However, it will not compile.
>
> Sounds like y.tab.[ch] never got (re)built from parse.y. Try renaming them
> to -old and give the 'make' command again. If you don't have yacc or bison,
> that'll fail. Get and install bison and try again.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]