bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: updating shopt compat settings to include current version


From: Chet Ramey
Subject: Re: updating shopt compat settings to include current version
Date: Fri, 16 Oct 2015 14:26:19 -0400
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Thunderbird/38.2.0

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 10/16/15 11:37 AM, Chet Ramey wrote:

> unset BASH_COMPAT
> shopt -u compat31 compat32 compat40 compat41
> shopt -s compat42 2>/dev/null || :
> 
> to set shell_compatibility_level to 42 on bash versions >= bash-4.2.
> 
> (this needs the attached patch for bash-4.3 to fix a typo in shopt.def)

And, of course, you can just add

BASH_COMPAT=42

at the end to get around the unpatched bash-4.3 bug.

- -- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, ITS, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iEYEARECAAYFAlYhQUEACgkQu1hp8GTqdKsXiwCdFU97u8fYHyEo7S5twlxebnbQ
fa4AoJwkoOHzFACRjGo8QcDR5aM46g+j
=Eg20
-----END PGP SIGNATURE-----



reply via email to

[Prev in Thread] Current Thread [Next in Thread]