bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: break no longer breaks out of loops defined in an outer context


From: Chet Ramey
Subject: Re: break no longer breaks out of loops defined in an outer context
Date: Wed, 1 Mar 2017 14:41:15 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:45.0) Gecko/20100101 Thunderbird/45.7.1

On 3/1/17 11:48 AM, L A Walsh wrote:

> But the way it is now -- if someone is using a compat option
> for an earlier version, and now needs another compat option
> for some other incompat, then they have a problem.  I'm
> fairly sure that wasn't by design, as the compat options seem
> to have been meant to solve specific compat problems that
> people needed, as they came up -- not as a new, long-term
> feature to control various compat issues.

This is mostly true. The original intent of compatibility options was
to provide a "quick fix" for backwards compatibility issues until the
affected script writers had time to change and test their scripts.

That said, the intent was not to have script writers "freeze" their
scripts at some version of bash -- if you really need that, the best
way to do it is to carry around exactly that version of bash.  It was
always my intent that script writers make appropriate changes to
their scripts, and the compatibility version was there to buy them
time.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]