bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Potential Denial of Service Vulnerability in embedded commands - Bas


From: Chet Ramey
Subject: Re: Potential Denial of Service Vulnerability in embedded commands - Bash version 4.4.12(1) - Release
Date: Tue, 7 Nov 2017 09:55:41 -0500
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Thunderbird/52.4.0

On 11/7/17 6:58 AM, Alex Nichols wrote:
> Hi All,
> 
> 
> I’m an Ethical Hacking student at Coventry university and while doing some
> exploit development on my Linux boxes I stumbled across a bug in the bash
> 4.4.12(1) - release.

As others have explained, this is not a bug, nor is it any kind of security
problem. You have requested more memory than your operating system can
supply. The memory allocation request fails, and bash exits.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    address@hidden    http://cnswww.cns.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]