bug-bash
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Define $as_echo and $as_echo_n for backward compatibility.


From: Chet Ramey
Subject: Re: [PATCH] Define $as_echo and $as_echo_n for backward compatibility.
Date: Fri, 13 Mar 2020 15:41:23 -0400
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 3/13/20 3:32 PM, Eric Blake wrote:

> I'm wondering if Chet has an update on the matter (adding bug-bash).
> Repeating some context:
> https://www.mail-archive.com/address@hidden/msg04237.html
> was a mail to the POSIX folks last June complaining about how bash 5.0's
> change to allow \ to trigger globbing has unintended consequences, and
> breaks many existing configure scripts based on the contents of the current
> directory.  I know the Austin Group finally settled on wording that does
> indeed explicitly state that unpatched bash 5.0 is buggy:

Not exactly. The decision was that bash-5.0 conformed to the original
wording, so the group adopted new wording to standardize the bash-4.4
behavior. Bash-5.1 will revert to the bash-4.4 behavior; the change
has been in the devel branch since last October.

-- 
``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    address@hidden    http://tiswww.cwru.edu/~chet/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]