[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Is this a bug?

From: Chet Ramey
Subject: Re: Is this a bug?
Date: Thu, 20 Aug 2020 10:29:34 -0400
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 8/19/20 4:55 PM, George R Goffe wrote:
> Chet,
> I tried several times to create the problem. I think I succeeded. I did 
> install the "debuginfo" files I could find but it looks like libnss_sss.so's 
> debuginfo isn't built properly? It's supplied by sssd-client. I tried 
> installing sssd-client-debuginfo but it is already installed. I don't 
> remember doing that. Sigh... Somehow libnss_sss.so is referenced by bash? 
> That's what gdb thinks.

Yep, it needs it to get access to user and group data for things like tilde

> Anyway, I tried causing the problem. ls -al zzz<tab-key> and then ctrl-c with 
> seemingly no response. I'll have to try running gdb in another konsole so I 
> can watch what happens when I <ctrl-c>... I'll do that now. Stand by. 

The trace you sent shows readline waiting in pselect for user input, so it
must be after the directory read was interrupted.

The only thing I can suggest is to defer the attach in gdb until bash
appears frozen. That may not work, but it's better than what you got.

``The lyf so short, the craft so long to lerne.'' - Chaucer
                 ``Ars longa, vita brevis'' - Hippocrates
Chet Ramey, UTech, CWRU    chet@case.edu    http://tiswww.cwru.edu/~chet/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]