[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Is this a bug?

From: Ángel
Subject: Re: Is this a bug?
Date: Fri, 21 Aug 2020 00:07:09 +0200

On 2020-08-19 at 20:55 +0000, George R Goffe wrote:
> Chet,
> I tried several times to create the problem. I think I succeeded. I did 
> install the "debuginfo" files I could find but it looks like libnss_sss.so's 
> debuginfo isn't built properly? It's supplied by sssd-client. I tried 
> installing sssd-client-debuginfo but it is already installed. I don't 
> remember doing that. Sigh... Somehow libnss_sss.so is referenced by bash? 
> That's what gdb thinks.
> Anyway, I tried causing the problem. ls -al zzz<tab-key> and then ctrl-c with 
> seemingly no response. I'll have to try running gdb in another konsole so I 
> can watch what happens when I <ctrl-c>... I'll do that now. Stand by. 
> ....
> I'm still not certain that I'm doing it right. When I entered ls -al zzz<tab 
> key> bash froze. I went to the gdb konsole and typed in where but nothing 
> happened. Tried several times. Tried ctrl-c on the gbb console. Got gdb's 
> attention. Entered where. Here's the results:
> Please let me know if this helps or if you need me to do something different.
> Regards,
> George...

Since you mention sssd, and it is apparently loaded by bash, are the
users and groups list from a remote server (such as LDAP)?

That could cause bash (or whatever program which tries to determine the
name of a user/group) to freeze if its cache expired and it needs to
refetch those  from a remote server (e.g. it may be downloading the list
of all the users in the company).

Best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]