[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bash 5.1 fails parallel builds from source

From: Fazal Majid
Subject: Re: Bash 5.1 fails parallel builds from source
Date: Mon, 7 Dec 2020 18:44:01 +0000

> On Dec 7, 2020, at 15:37, Chet Ramey <chet.ramey@case.edu> wrote:
> On 12/7/20 7:31 AM, Fazal Majid wrote:
>> I occasionally encounter the error:
>> gcc  -DPROGRAM='"bash"' -DCONF_HOSTTYPE='"x86_64"' 
>> -DCONF_OSTYPE='"linux-musl"' -DCONF_MACHTYPE='"x86_64-pc-linux-musl"' 
>> -DCONF_VENDOR='"pc"' -DLOCALEDIR='"/usr/local/share/locale"' 
>> -DPACKAGE='"bash"' -DSHELL -DHAVE_CONFIG_H   -I.  -I. -I./include -I./lib    
>> -g -O2 -Wno-parentheses -Wno-format-security -c list.c
>> bashline.c:65:10: fatal error: builtins/builtext.h: No such file or directory
>>    65 | #include "builtins/builtext.h"  /* for read_builtin */
>>       |          ^~~~~~~~~~~~~~~~~~~~~
>> compilation terminated.
>> That's because bashline.o does not have a dependency on builtins/builtext.h 
>> in Makefile, unlike sig,o, subst.o etc
> Thanks for the report. I've never actually encountered this error. Just
> lucky, I guess.

It’s a race condition. The machine I run it on has 6 cores and HT, so I run it 
with a `make -j 12`, and even then, it’s not consistently reproducible.

Fazal Majidwww.majid.info

reply via email to

[Prev in Thread] Current Thread [Next in Thread]