[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

A bash bug? sh_malloc missing

From: George R Goffe
Subject: A bash bug? sh_malloc missing
Date: Mon, 1 Feb 2021 22:29:49 +0000 (UTC)


I just checked out the "latest" bash from the repo at savanna.gnu.org and am 
having build problems.

I have tried --with-gnu-malloc and it's alias and also tried building without 
any malloc parameters in configure without success. Enclosed below is what I'm 
seeing. I have a full build log available if needed.

Regards and THANKS for your help,


gcc  -DHAVE_CONFIG_H -DSHELL  -I. -I..  -I.. -I../include -I../lib -I.    -g 
-O2 -Wno-parentheses -Wno-format-security  -rdynamic -g -O2 -Wno-parentheses 
-Wno-format-security -rdynamic -g -O2 -Wno-parentheses -Wno-format-security  -o 
gen-helpfiles gen-helpfiles.o tmpbuiltins.o -ldl
 DWARF error: can't find .debug_ranges section.
gen-helpfiles.o: in function `write_helpfiles':
gen-helpfiles.c:(.text+0xdc): undefined reference to `sh_malloc'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:185: gen-helpfiles] Error 1
make[1]: Leaving directory '/export/home/tools/bash/bash/builtins'
make: *** [Makefile:737: builtins/libbuiltins.a] Error 1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]