[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

building 5.1.3 -- some probs...

From: L A Walsh
Subject: building 5.1.3 -- some probs...
Date: Mon, 22 Feb 2021 17:08:31 -0800
User-agent: Thunderbird (Windows/20100228)

I'm trying to build bash 5.1.3, and at first
I tried w/bash-malloc, but got:
/bash-5.1> ./bash

malloc: subst.c:4751: assertion botched
free: called with unallocated block argument
Aborting...Aborted (core dumped)

Another prob which seems a bit odd -- more than once, on the
first time after a make clean+ rerun config, then
doing a 'make -j 6', I've gotten a:
/usr/bin/gcc -DPROGRAM='"bash"' -DCONF_HOSTTYPE='"x86_64"' -DCONF_OSTYPE='"linux-gnu"' -DCONF_MACHTYPE='"x86_64-pc-linux-gnu"' -DCONF_VENDOR='"pc"' -DLOCALEDIR='"//share/locale"' -DPACKAGE='"bash"' -DSHELL -DHAVE_CONFIG_H -I. -I. -I./include -I./lib -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -c stringlib.c bashline.c:65:10: fatal error: builtins/builtext.h: No such file or directory
#include "builtins/builtext.h"  /* for read_builtin */
compilation terminated.
make: *** [Makefile:101: bashline.o] Error 1
make: *** Waiting for unfinished jobs....
/usr/lib64/gcc/x86_64-suse-linux/8/../../../../x86_64-suse-linux/bin/ld: total time in link: 0.020174
./mkbuiltins -externfile builtext.h -structfile builtins.c \
-noproduction -D . ./alias.def ./bind.def ./break.def ./builtin.def ./caller.def ./cd.def ./colon.def ./command.def ./declare.def ./echo.def ./enable.def ./eval.def ./getopts.def ./exec.def ./exit.def ./fc.def ./fg_bg.def ./hash.def ./help.def ./history.def ./jobs.def ./kill.def ./let.def ./read.def ./return.def ./set.def ./setattr.def ./shift.def ./source.def ./suspend.def ./test.def ./times.def ./trap.def ./type.def ./ulimit.def ./umask.def ./wait.def ./reserved.def ./pushd.def ./shopt.def ./printf.def ./complete.def ./mapfile.def
make[1]: Leaving directory '/home/tools/bash/bash-5.1/builtins'

However, then I find if I do a 'make' and no -j, it finally ends w/no error, but running I still get a core dump:
bash-5.1> ./bash

malloc: subst.c:4751: assertion botched
free: called with unallocated block argument
Aborting...Aborted (core dumped)

The config I tried:
declare -a enable=(
   alias arith-for-command array-variables
   casemod-attributes casemod-expansions command-timing
   cond-command cond-regexp coprocesses
   directory-stack disabled-builtins
   extended-glob extended-glob-default function-import
   help-builtin history
   process-substitution progcomp prompt-string-decoding
   readline select single-help-strings

declare -a disable=( nls rpath )
declare -a with=( gnu-ld installed-readline bash-malloc)
declare -a without=()

FWIW, I just tried a make clean followed by a plain make (no
parallel, and it did build, but same core dump.  Also,
my final 'link' step for bash:
make[1]: Leaving directory '/home/tools/bash/bash-5.1/lib/malloc'
rm -f bash
/usr/bin/gcc -L./builtins -L./lib/readline -L./lib/readline -L./lib/glob -L./lib/tilde -L./lib/malloc -L./lib/sh -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -Wl,--default-imported-symver -Wl,--default-symver -Wl,--stats -rdynamic -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -fpic -march=native -pipe -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -flto -Wl,--no-as-needed -Og -g3 -ggdb -o bash shell.o eval.o y.tab.o general.o make_cmd.o print_cmd.o dispose_cmd.o execute_cmd.o variables.o copy_cmd.o error.o expr.o flags.o jobs.o subst.o hashcmd.o hashlib.o mailcheck.o trap.o input.o unwind_prot.o pathexp.o sig.o test.o version.o alias.o array.o arrayfunc.o assoc.o braces.o bracecomp.o bashhist.o bashline.o list.o stringlib.o locale.o findcmd.o redir.o pcomplete.o pcomplib.o syntax.o xmalloc.o -lbuiltins -lglob -lsh -lreadline -lhistory -ltermcap -ltilde -lmalloc -ldl /usr/lib64/gcc/x86_64-suse-linux/8/../../../../x86_64-suse-linux/bin/ld: /tmp/ccbVWxpp.ltrans3.ltrans.o: in function `sh_mktmpname': /home/tools/bash/bash-5.1/tmpfile.c:160: warning: the use of `mktemp' is dangerous, better use `mkstemp' or `mkdtemp' /usr/lib64/gcc/x86_64-suse-linux/8/../../../../x86_64-suse-linux/bin/ld: total time in link: 0.252064
ls -l bash
-rwxrwxr-x 1 law lawgroup 5857880 Feb 22 17:02 bash
size bash
  text    data     bss     dec     hex filename
1099343   47512   45504 1192359  1231a7 bash

It builds a final file, "support" following that link.

I seem to remember having a similar problem building bash-5.0 some ages back.

If you see something obvious that I'm doing wrong, please let me know.
Otherwise, guess I'll poke at it to see if I come up with anything.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]