[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: question about "invalid string offset" & "could not read symbols: Ma

From: Nick Clifton
Subject: Re: question about "invalid string offset" & "could not read symbols: Malformed archive" linker errors (fwd)
Date: Fri, 22 Aug 2008 17:13:22 +0100
User-agent: Thunderbird (X11/20080723)

Hi Roger,

We built the libxvtmapi.a ourselves. Yes, I've tried deleting it and rebuilding but I still get the file format not recognized error message. The build procedure seems to work fine otherwise, though there are some warning messages. That said, I haven't seen any warning messages that seem to be related to this issue.
[If all else fails, try fixing the warnings anyway... :-)]
address@hidden testapp]$ objdump -p outdir/debug/libxvtxmapi.a In archive outdir/debug/libxvtxmapi.a:
objdump: tapp.o: File format not recognized
objdump: outdir/debug/libxvtxmapi.a: Malformed archive
This is the cause of the problem - the tapp.o file is not recognized. One possible cause for this is that the compiler used to build the tapp.o file is targeted at one particular processor type and the binutils (including objdump and the linker) are targeted at a different system type. To check this have a look at the output of "objdump --help" and compare the supported targets list with the target displayed as part of the output of "gcc --verbose".

Here is the tapp.o file:

address@hidden testapp]$ find . -name tapp.o
What does "objdump -p tapp.o" report ? Is it still unrecognized ? (If not then this is very worrying. It would mean that placing the tapp.o file into the libxvtxmapi.a archive has corrupted it).

How was tapp.o built ? (Ie what was the command line used to compile it and to assemble it).


reply via email to

[Prev in Thread] Current Thread [Next in Thread]