[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: ftpcmd.y -- syntax error

From: Hans Aberg
Subject: RE: ftpcmd.y -- syntax error
Date: Tue, 6 Apr 2004 18:53:16 +0200

At 08:33 -0400 2004/04/06, Jacques Dejean wrote:
>Hello Hans,

Don't forget to cc Bison Help, so others get to know.

>I discovered yesterday that the problem is with 'bison -y'.  I ran 'bison -y
>ftpcmd.y' and got errors.  If I either remove the equal sign (=) from the
>syntax or enclose it in quotes ('='), 'bison -y' will compile ok; however,
>the final executable (ftpd) will refuse connection.  I changed 'bison -y' to
>'yacc', and it worked successfully.  The final executable 'ftpd' works as
>expected.  What is the difference between 'bison -y' and 'yacc'?  Isn't
>"bison -y" supposed to function as 'yacc'?

Assuming that what you say is correct, it would be bug, to be reported at
Bug-Bison <address@hidden, as -y and -yacc should be equivalent. Your
claim is mysterious, as Bison should be rigged so that these options must
be equivalent.

Further, the manual states that -y/-yacc merely changes the output file
names. I think that currently, Bison has developed so far that these
options ought to ensure full yacc compatibility.

Bison in its basic mode should be developed according to the POSIX
standards according for Yacc:

Paul, what does Yacc say about an unquoted = in a grammar rule?

  Hans Aberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]