[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bison 2.0 test suite on Mac OS X.3.8

From: Hans Aberg
Subject: Re: Bison 2.0 test suite on Mac OS X.3.8
Date: Mon, 21 Mar 2005 18:54:49 +0100

At 23:02 -0800 2005/03/20, Paul Eggert wrote:
 > 5. input.at:130: testing ...
 input.at:136: bison input.y
 input.at:266: bison -d -v -o input.c input.y
 input.at:267: $CC $CFLAGS $CPPFLAGS -c input.c -o input.o
 gcc: cannot specify -o with -c or -S and multiple compilations

What are CC, CFLAGS, and CPPFLAGS set to on your host?  That
might explain the problem.

Do you mind to help me a bit on this. -- I have just installed UNIX and I have not run it for a couple of years. How do I check those values, what should they be set to, and how do I set them (system-wide)?

It is a bit strange that maiking bison works, without those flags then, but the test suite fails. How is it setup in the "make" of Bison, as these falgs then are not needed?

Can you reproduce the problem with a simple command that you can
run separately?  E.g.:

gcc -c input.c -o input.o

I have not tried this, but I have installed latest versions of m4 and guile, and it worked fine. So I guess it is the flag thing that is the problem.

Bison doesn't expect or need any version of flex or yacc, if all you
want to do is run "configure; make; make check; make install".  It is
supposed to work with any C compiler in current use.

Compiling Bison went fine. It was the "make check" part that failed.

 > I also found a bug in the test suite, when the path name of directory
 contains a space.

Bison doesn't support that, alas.  It would be some work to fix this.
If you have patches in this area by all means please submit them.

I noticed this and thought I should report it. I resolved it by changing to a directory path (from HOME) without spaces in it.

  Hans Aberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]