[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: a probalem with Bison

From: josephus
Subject: Re: a probalem with Bison
Date: Sun, 05 Jun 2005 14:16:52 -0500
User-agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.8) Gecko/20050511

Paul Eggert wrote:

josephus <address@hidden> writes:

Algol.h is made with bison -v -d algol.y

No, that command creates "algol.tab.h", not "algol.h".  Nor does it
help if I manually rename the former to the latter; your stuff still
doesn't compile for me.

But I start with just what you have.  I make the include file and make
any changes I need.

I made it with the tools. Maybe it was flex but the symbols come from the grammar file. I have a different file with different symbols and I have to recompile after bison -d you should be able to use the symbol list from algol.tab.h and just rename that file. I often just add symbols to that file (algol.h) to make it work for some change I made. so it is not clear what is wrong. I started with algol.y and algol.l and I made algol.h from them. I made it a year ago with yacc.
Not byacc. I seem to remember changing the name.

I have that ancient yacc from Berkley. -d generates an h file. And I have an older version of flex. I may have built the first algol.h from that and I would have had to changed the name. But that was on an ATARI. My problem on the ATARI was every time I tried I had to replace the machine or the disk. I got a PC and put Linux on a major partition. It took the stress off my ATARI. I moved my sources and worked my way up to this problem.

tell me how to fix the M4 fault

I went back and started mucking with the .h file. bison20a does not generate a .h file. -d does nothing.

sometimes it will but mostly it won't and I can't find any reason for the difference. I run the commands yacc, byyac and bison I know they are scripts for bison. I get the M4 fault with all of them. But I get different parsing tables. I should not.


Can you please send a complete, self-contained test case, that
contains all the files that one would need to recreate the problem,
along with detailed instructions about how to reproduce it?  I still
don't know what your problem is, and so I can't reproduce it.

I have a small problem with Bison.20.a It wants
sugarm4/sugarM4.m4 and it does not exist on my system.

This suggests that you have an installation problem on your host.
"make install" should have put m4sugar into a file with a name like
/usr/local/share/bison/m4sugar/m4sugar.m4, and Bison should be
able to use that file when it runs.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]