[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: %destructor feedback

From: Paul Eggert
Subject: Re: %destructor feedback
Date: Wed, 04 Jan 2006 11:42:27 -0800
User-agent: Gnus/5.1007 (Gnus v5.10.7) Emacs/21.4 (gnu/linux)

Akim Demaille <address@hidden> writes:

> Paul, in English you'd write mid-rule action, right?


> And in code? mid_rule, midrule?

Either would be fine.  Currently the code uses both spellings (in
different contexts), which is confusing.  I mildly prefer "midrule" as
it's shorter and combines better with other things, e.g.,
"grammar_midrule_action" is slightly easier to read than

>       USE (($1, $2, $<foo>3, $<bar>4, $5));

That is indeed annoying.  I suppose, though, that if someone writes
code that bad they deserve to get annoyed.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]