[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installing Bison from CVS

From: Hans Aberg
Subject: Re: Installing Bison from CVS
Date: Sat, 28 Apr 2007 20:29:11 +0200

On 28 Apr 2007, at 19:58, Joel E. Denny wrote:

If it's using an old version, reinstall Autoconf.

I did that, and it did not help.

It worked for me and at least two others, so I recommend you keep trying this. If you're still getting the same error from the command I sent you, then Autoconf is surely running an old version of M4. You need to find a
way to configure Autoconf to use the right version.

Actually, I have found the error: there is a bug in Autoconf; it uses not 'm4' but 'gm4', and later versions of M4 does not install it, it seems. So I made a soft link
  /usr/local/bin/gm4 -> /usr/local/bin/m4
and then reinstalled Autoconf with './configure && make && make install'. Then root# `echo 'm4_divert(0)__program__' | autom4te --language=m4sugar` --version
m4 (GNU M4) 1.4.9
And Bison '.bootrap now works.

I found this because of your comment, and by running
  autom4te --language=m4sugar
then entering 'm4_divert(0)__program__' at the console; when aborting, I got the message that /usr/bin/gm4 is used.

So, in summary, one might keep reinstalling Autoconfig forever :-), not fixing the problem. It will work on older systems having this soft link gm4 -> m4.

  Hans Aberg

reply via email to

[Prev in Thread] Current Thread [Next in Thread]