[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Difficulty trying to build distribution from CVS sources

From: Juan Manuel Guerrero
Subject: Re: Difficulty trying to build distribution from CVS sources
Date: Mon, 21 Apr 2008 21:06:31 +0200
User-agent: KMail/1.9.5

Am Montag, 21. April 2008 20:16 schrieben Sie:
> On Mon, 21 Apr 2008, Joel E. Denny wrote:
> Well, it's a little later.  Let's see if I can get it right this time....
> I recall now that I never rechecked make dist after switching to the new 
> gnulib repository.  It turns out that there were changes to 
> git-version-gen that broke make dist again.  I committed the following 
> patch, which fixes it for me.  I tried with and without git installed.
> I guess we need another sync with coreutils.  For example, it seems 
> GNUmakefile is now part of gnulib, and it has updates too.

Now it works better.  The infinite loop no longer appeares.  The directory
bison-2.3a+ is created and populated with the required files, neitherless
the dist target breakes with the following output:

make[2]: Leaving directory `/home/jmg/bison/examples/calc++'
make[1]: Leaving directory `/home/jmg/bison/examples'
make[1]: Entering directory `/home/jmg/bison/tests'
/bin/sh /home/jmg/bison/build-aux/missing --run autom4te --language=autotest -I 
                                                           . testsuite.at -o 
/usr/local/bin/m4:output.at:189: ERROR: end of file in string
autom4te: /usr/local/bin/m4 failed with exit status: 1
make[1]: *** [testsuite] Error 1
make[1]: Leaving directory `/home/jmg/bison/tests'
make: *** [distdir] Fehler 1

BTW, the testsuite continue breaking with the same error message as
posted before.

Juan M. Guerrero

reply via email to

[Prev in Thread] Current Thread [Next in Thread]