[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: A bit more info about hanging bison on tru64 5.1b

From: Didier Godefroy
Subject: Re: A bit more info about hanging bison on tru64 5.1b
Date: Thu, 25 Jun 2009 20:54:36 +0200
User-agent: Microsoft-Entourage/

on 6/25/09 1:58 PM, Akim Demaille at address@hidden uttered the

> GNU M4 1.4.9?
> That's not very recent.  If you can upgrade, that would be nice.
> Bison requires GNU m4, not a plain M4.

Ok. I remembered upgrading m4 not so long ago. Actually it's been close to a
couple of years.
I upgraded m4 to:

m4 (GNU M4) 1.4.13

It compiled and tested ok.

>> ./tests/bison --trace=m4 test-2.y </dev/null 2>m4.log
>> Hangs and the m4.log is actually quite short:
>> test-2.y:6.4-14: warning: unused value: $2
>> That's all there is in there.
> That's bizarre, it means m4 didn't even start.

That's what I thought was odd.

> Could you try
>> ./tests/bison --trace=m4,muscles,tools test-2.y </dev/null 2>m4.log

Just tried it, with the upgraded m4 and it gave me this in the m4.log:

/usr/local/bison/src/src/bison: invalid argument `muscles' for `--trace'
Valid arguments are:
  - `none       - no traces'
  - `scan       - grammar scanner traces'
  - `parse      - grammar parser traces'
  - `automaton  - construction of the automaton'
  - `bitsets    - use of bitsets'
  - `grammar    - reading, reducing the grammar'
  - `resource   - memory consumption (where available)'
  - `sets       - grammar sets: firsts, nullable etc.'
  - `tools      - m4 invocation'
  - `m4         - m4 traces'
  - `skeleton   - skeleton postprocessing'
  - `time       - time consumption'
  - `all        - all of the above'

So I tried just:

./tests/bison --trace=m4,tools test-2.y </dev/null 2>m4.log

And it hangs again. m4.log has:

test-2.y:6.4-14: warning: unused value: $2
running: /usr/bin/gm4 /usr/local/bison/src/data/m4sugar/m4sugar.m4 -
/usr/local/bison/src/data/bison.m4 /usr/local/bison/src/data/c-skel.m4

Just for kicks, I ran:

./tests/bison --trace=all test-2.y </dev/null 2>m4.log

And I'm attaching the m4.log

It's probably all linked. I had the problem with flex and gcc giving me
similar issues..

Didier Godefroy
Support anti-Spam legislation.
Join the fight http://www.cauce.org/

Attachment: m4.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]