[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SOLVED] Re: Bootstrapping a freshly-cloned Git repository of Bison fail

From: Stefano Lattarini
Subject: [SOLVED] Re: Bootstrapping a freshly-cloned Git repository of Bison fails
Date: Wed, 26 Dec 2012 15:16:50 +0100

On 12/26/2012 11:09 AM, Akim Demaille wrote:
> Le 21 déc. 2012 à 18:06, Stefano Lattarini <address@hidden> a écrit :
>>  configure.ac:168: error: possibly undefined macro: AC_PROG_GNU_M4
>>        If this token and others are legitimate, please use m4_pattern_allow.
>>        See the Autoconf documentation.
>>  autoreconf: /usr/bin/autoconf failed with exit status: 1
>>  ./bootstrap: autoreconf failed
>> Maybe this could be fixed by suitably invoking "git submodule"
>> in the 'bootstrap_post_import_hook' function (to be defined in
>> bootstrap.conf).  I didn't attempt a patch because I have no
>> copyright paperwork in place for Bison.
> Hi Stefano,
> I personally consider that playing with git submodules is none
> of the business of bootstrap.  Actually, it's a PITN that it
> changes my gnulib checkout when I bootstrap to check changes,
> it forces me to commit the changes.
> I don't plan to change this; git submodule update --init
> is the normal course of action, as documented in README-hecking.
> I would happily remove the automatic update of gnulib.
OK, noted.  And indeed, if I follow more carefully the instructions
in README-hacking, I can bootstrap and compile without issues.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]