[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

A question the --disable-dependency-tracing behavior in bison-3.0.2

From: Juan Manuel Guerrero
Subject: A question the --disable-dependency-tracing behavior in bison-3.0.2
Date: Sat, 12 Jul 2014 15:40:10 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

I have tried to build bison-3.0.2.tar.gz on linux and on windows using DJGPP.
In both cases I experienced the same difficulty.  I created a build directory
below the bison-3.0.2 directory.  From the build directory I started the
configuration script like this:
  ../configure --disable-dependency-tracing
At a first glance the configuration worked flawlessly, but when I started make
I got the following error output:

rm -f examples/extracted.stamp examples/extracted.stamp.tmp
touch examples/extracted.stamp.tmp
touch: cannot touch `examples/extracted.stamp.tmp': No such file or directory
make: *** [examples/extracted.stamp] Fehler 1

The reason is quite clear, if I pass the --disable-dependency-tracing option
to the configure script the examples directory and all its sub-directories are
not created making the makefile fail  (see config.status line 2970.      At that
line the following is tested:
  test x"$AMDEP_TRUE" != x""
For --disable-dependency-tracing, AMDEP_TRUE will be set to #.).

As soon as I remove --disable-dependency-tracing from the argument list I pass
to the configure scripts everything works.  Neither less the question remains if
this a bug or a feature?  IMHO if --disable-dependency-tracing is not allowed
to configure bison then it should be removed.  But I have seen no comment about
the usage of --disable-dependency-tracing neither in the README nor in the NEWS
nor INSTALL files.

Juan M. Guerrero

reply via email to

[Prev in Thread] Current Thread [Next in Thread]