[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build problems: bison 3.7.1 + other versions

From: Akim Demaille
Subject: Re: Build problems: bison 3.7.1 + other versions
Date: Fri, 4 Sep 2020 06:34:59 +0200

Hi Claudio,

> Le 3 sept. 2020 à 10:20, Claudio Calvelli <bugb@w42.org> a écrit :
> I've first encountered this problem while installing the Gentoo package
> for bison 3.6.4 but it seems to persist in other versions and is definitely
> present in 3.7.1.
> It is related to a parallel build, and it appears to be a dependency
> problem; and reproducing it requires giving "make" some options which
> seem to depend on the exact processor being used; however once found
> the right options the problem is 100% repeatable, "make" with the
> same options fails every time with the same error.  The error itself
> also depends on the type of parallel build, but it suggests that some
> files are not generated before building an object which requires them.
> I'm including below examples of how to trigger the problem on three
> different processors, hoping that this helps somebody to reproduce
> the problem on other systems.  The exact value of the "-l" option
> doesn't quite matter as I've tried small ranges, but it needs to
> be there together with the "-j" to trigger a problem.

Thanks a lot for this bug report!  This had already been reported
before (https://github.com/akimd/bison/issues/31) and a workaround
was submitted 

But I was unable to reproduce the problem and fix the core issue.
Thanks to your findings, I might be able to find the real problem
and fix it soon.

Thanks again!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]