[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Socket's close() doesn't close connection (bug back again?)

From: Gerhard H.
Subject: Socket's close() doesn't close connection (bug back again?)
Date: Fri, 31 Jul 2009 10:15:57 +0200
User-agent: Thunderbird (X11/20080925)


I have got the same problem with classpath 0.96.1 and jamVm 1.5.0 on
Gumstix (Arm-Linux platform) which was already solved in the past?
see Bug report of David (from 2005!):
The Test (SocketClose.java) still fails:

I checked the sourcecode from natPlainSocketImplPosix.cc in my
openEmbedded Build system and the fix from Bug 15430 is there ...

I tried SocketClose.java on Ubuntu 8.04.2 and there it failed as well. I
tested it against the following versions:
1) JamVm v1.4.5 und classpath 0.96.1 (both just installed using the
ubuntu package manager) and
2) JamVm v1.5.0 und classpath 0.96.1 (compiled JamVm by myself) - same
versions as on gumstix!!! in this configuration ...

At the moment I try to get to compile classpath 0.98 on ubuntu 8.04, but
I have big troubles to get to compile it there ... dependig on the
installed java jdk I end up always on some option not supported during
make .... quite frustrating at the moment ...

FYI: I also started a thread at the gumstix mailing list, but no
response till now: see

Could it depend on the on the javaJdk installed for building classpath?
I used eclipse-ecj for gumstix (see
http://code.google.com/p/netbeams/wiki/GumstixOESystem). No idea what
the Ubuntu guys were using for building the packages on Ubuntu 8.04?

Hope that I am not too wrong in this list. Would another one be better?

cheers Gerhard

reply via email to

[Prev in Thread] Current Thread [Next in Thread]