bug-coreutils
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[patch #4600] Addition of "dups" file utility to GNU Core Utilities


From: anonymous
Subject: [patch #4600] Addition of "dups" file utility to GNU Core Utilities
Date: Sat, 5 Nov 2005 20:09:25 +0000
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Follow-up Comment #1, patch #4600 (project coreutils):

Just some constructive criticism:

- doesn't accept long option names
- doesn't accept --help and --version that every GNU util should recognise
- no ChangeLog entries included
- no texinfo documentation or help2man output
- coding style does not match the GNU coding standards
- messages should be localized with _("") for use with gettext
- comparing files one byte at a time with getc() is extremely inefficient
- it should read each file at most once and store a hash, otherwise
performance is going to be horrendous (O(N^2)) when the number of files
and/or the file size is large
- if the link() fails (such as two files on different volumes) it leaves
things in a bad state because it's already committed to unlinking one of the
files.  This is a very bad thing since it's now caused permanent data loss. 
It should at the least check if they are on the same volume first before
continuing, and additionally it should rename one until the link() succeeds,
so that it rename it back to its original name if the link fails.

    _______________________________________________________

Reply to this item at:

  <http://savannah.gnu.org/patch/?func=detailitem&item_id=4600>

_______________________________________________
  Message sent via/by Savannah
  http://savannah.gnu.org/





reply via email to

[Prev in Thread] Current Thread [Next in Thread]