[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#10136: Can't view some strange characters in some of the man pages

From: Bob Proulx
Subject: bug#10136: Can't view some strange characters in some of the man pages
Date: Fri, 25 Nov 2011 15:03:35 -0700
User-agent: Mutt/1.5.21 (2010-09-15)

Alan Curry wrote:
> Harold Raulston writes:
> > Could you tell me what encoding I need to use to view your man pages?
> > 
> > I've tried Unicode, Western, Western ISO, but still get some unreadable
> > characters in the EXAMPLES (I've just looked at the find and du commands so
> > far):
> > 
> > â€â€™ linuxcommand find1 can't display read

I do not see any unicode characters in the man page even with LC_ALL
set to en_US.UTF-8.

> > BTW, I'm using Win7 Pro English, IE9. All latest updates.
> > I have the same problem in Chrome...
> man pages are read with the man program. HTML is Not The Way.


Harold, you said IE9 in the same message talking about man pages.
This creates confusion.  Man pages are read with the man program.

  $ man du

But if you are using the web browser then it sounds like you are
looking at a web page instead?  If that is true then the web page you
are looking at will be the problem.

Harold, Please tell us what web page URL to which you are referering.

Documentation for the coreutils is available on the web here:


All of those pages look okay to me.  For 'du' here is the relevant
documentation page on the web.


And of course the info pages should be installed on your system.  You
can access them using the 'info' command.

  $ info coreutils

> [c3 a2 e2 82 ac c3 a2 e2 82 ac e2 84 a2] is what you get when you start with
> U+2019 RIGHT SINGLE QUOTATION MARK in UTF8, then misinterpret it as
> windows-1252 and convert it to UTF8 again.

Good observation.

> We were *so* unfortunate when we didn't have all these extra kinds of
> quotation marks.

/me shakes head, People do like eye candy.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]