[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#50151: Coreutils, aarch64 and chroot

From: Frans de Boer
Subject: bug#50151: Coreutils, aarch64 and chroot
Date: Thu, 26 Aug 2021 11:14:10 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.0.1

On 8/26/21 10:19, Andreas Schwab wrote:
On Aug 26 2021, Frans de Boer wrote:

I was not sure, but I tried the same also with x86_64 cross compiled
programs using qemu-i386, which worked.
Of course, they can be natively executed.


I understand now better how things are connected. Until some time ago I always used qemu-system-xxx, but have failed to understand that the qemu-xxx user emulation is only about the cpu. So, starting programs with a different coding will fail. The binfmt is the way to solve this issue. Now only find a decent explanation how to setup the /etc/binfmt.d/register for the aarch64, powerpc and maybe other architectures. At kernel.org there is an explanation, but fairly limited and thus not very helpful at this point in time.

I keep on digging.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]