bug-ddd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

DDD is stuck at startup


From: Sik Ngai
Subject: DDD is stuck at startup
Date: Tue, 17 Jun 2003 17:41:05 -0600

I built ddd 3.3.1 on powerpc-ibm-aix5.2.0.0 using xlc_r and xlC_r compilers
and Motif 2.1 shipped with AIX.

When I ran it, the program came up, but the console prompt was greyed out.
If I stopped it by closing the application, it gave my the dialog saying dbx
was busy. When ddd was stopped this way, I got:
   /bin/sh -c 'exec dbx' [<process id>]: Hangup
on the launching shell.

If I tried the /bin/sh command as displayed above, everything was fine and I
could run dbx successfully.


If instead of closing the app, I did a control-C in the console pane, ddd
gave an segmentation fault, with the following text:

vvv

/bin/sh: gdb:  not found.

Internal error (Segmentation fault).

Oops!  You have found a bug in DDD.

If you can reproduce this bug, please send a bug report
to <address@hidden>, giving a subject like

    DDD 3.3.1 (powerpc-ibm-aix5.2.0.0) gets `Segmentation fault' signal

To enable us to fix the bug, you should include the following information:
* What you were doing to get this message.  Report all the facts.
* The contents of the `~/.ddd/log' file as generated by this session.
Please read also the section "Reporting Bugs" in the DDD manual.

We thank you for your support.

Segmentation fault (core dumped)

^^^

I guess it is because of gdb not being there. But still ....

A stack print of the generated core file is:

(dbx) where
pthread_kill(??, ??) at 0xd005b140
_p_raise(??) at 0xd005abc8
ddd_signal(int,...)(0xb), line 378 in "exit.C"
ddd_fatal(int,...)(0xb), line 506 in "exit.C"
GDBAgent.operator=(const char*)(0xf0, 0x10358b64), line 988 in "strclass.h"
handle_died()(0x0), line 1599 in "GDBAgent.C"
DiedHP(Agent*,void*,void*)(0x200a03d8, 0x0, 0xf01849f8), line 1593 in
"GDBAgent.C"
unnamed block $b331, line 152 in "HandlerL.C"
call(unsigned int,void*,void*) const(0x200a0400, 0x6, 0x200a03d8,
0xf01849f8), line 152 in "HandlerL.C"
Agent.callHandlers(int,void*)(0x200a03d8, 0x6, 0xf01849f8), line 175 in
"Agent.h"
abort()(0x200a03d8), line 542 in "Agent.C"
unnamed block $b320, line 239 in "AsyncAgent.C"
unnamed block $b319, line 239 in "AsyncAgent.C"
abort()(0x200a03d8), line 239 in "AsyncAgent.C"
abort()(0x200a03d8), line 481 in "LiterateA.C"
abort()(0x200a03d8), line 3098 in "GDBAgent.C"
hasNewStatus(int)(0x200a03d8, 0x20002), line 344 in "Agent.C"
unnamed block $b289, line 313 in "Agent.C"
running()(0x200a03d8), line 313 in "Agent.C"
unnamed block $b117, line 3095 in "ddd.C"
process_next_event()(), line 3095 in "ddd.C"
ddd_main_loop()(), line 106 in "mainloop.C"
main(argc = 1, argv = 0x2ff22434), line 3075 in "ddd.C"


Any idea as to why ddd thinks dbx is not done initialising is appreciated.


Sik Ngai
E: address@hidden






reply via email to

[Prev in Thread] Current Thread [Next in Thread]