[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-ddrescue] Mac OS X, 10.5.5, MacBook Pro 120 GB drive recovery

From: Melissa Graesser
Subject: [Bug-ddrescue] Mac OS X, 10.5.5, MacBook Pro 120 GB drive recovery
Date: Mon, 6 Oct 2008 22:27:30 -0600


First, I do want to thank you for creating ddrescue. I have not yet recovered my data but am hopeful. I have tried several other tools, TechTool Pro, Disk Warrior, Stellar Phoenix, with not much luck. I like the ddrescue feature that allows me to stop it and then restart it. I am in the process of recovering a failing hard drive using ddrescue 1.8 which I built. My drive has never been dropped or anything it just would not wake up from sleep one day and after a force reboot the MacBook cannot find the system or drive. Disk Utility can see it but said the b-tree was corrupted when I tried to verify it. Disk Utility cannot mount the drive. Disk Warrior gets many errors. Apple is scheduled to replace the drive under AppleCare, but I will not be able to get my drive back or any chance of recovering data. So, I was very happy when I found ddrescue. I think my drive has several bad blocks. So I told ddrescue to skip the bad blocks with the -n option. It has been running for 8 days now and should finish tomorrow at the rate it is going. My hard drive I am recovering is 120 GB SATA, Hitachi. I ran ddrescue with the commands:

sudo ./ddrescue -v -n /dev/disk1s2 MyVolImage.dmg MyVolRescue.log

My question is ddrescue reports, errors: 1071 and errsize: 28775 MB. So I still have a lot of data that has not been recovered. After ddresue is finished for the first pass I would like to try and recover more if possible with the parameters -r 2 so it will retry twice. Does ddrescue automatically try going backwards after it has finished or do I need to specify I want it to try. After it finished before trying to recover more data I was going to copy the image over to a new hard drive partition on an external fire wire drive which I have created a partition of the same size as my original bad hard drive was, 111.5 GB. This is the size Disk Utility reports even though it is 120 GB hard disk. I am assuming the drive has already blocked out bad blocks because the difference in 120 and 111 is more then the usual. I have read these drives try to do that. Then I am assuming I will have to run Tech Tool Pro to clean the image up.

I am running everything from an external hard drive right now.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]