[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-ddrescue] Log file problems

From: Matthew Vukomanovic
Subject: [Bug-ddrescue] Log file problems
Date: Tue, 24 Jul 2012 12:42:51 +0800

System ubuntu live cd

ddrescue 1.16
compiled with c++ from g++
c++ (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3

Hi I was restoring a 1tb hard drive onto a 3tb hard drive and had most of the content from it copied.

It had about 2mb of data which i was going to run a final run over after putting the hard drive in the freezer.
However when it finished suddently the log file was only a single line (instead of having about 250 lines like it did during it's run)

I should have kept a copy of the log file at that point but i didn't think of it.

When i ran the ddrescue on it the last time the numbers were going up in TB's rather than KB or MB (So i did a Ctrl+C)

This is the start of the log file

# Rescue Logfile. Created by GNU ddrescue version 1.16
# Command line: ddrescue -d -f -r3 /dev/sdd /dev/sdb /media/storage/1tb.log
# current_pos  current_status
0x781D7A66F3CE00     ?
#      pos        size  status
0x00000000  0x2608B000  +
0x2608B000  0x00005000  *
0x26090000  0x00000200  -
0x26090200  0x00010000  *
0x260A0200  0x00000200  -
0x260A0400  0x00020000  *
0x260C0400  0x00000200  -
0x260C0600  0x00040000  *
0x26100600  0x00000200  -
0x26100800  0x00080000  *
0x26180800  0x00000200  -
0x26180A00  0x00100000  *
0x26280A00  0x00000200  -
0x26280C00  0x00200000  *
0x26480C00  0x00000200  -
0x26480E00  0x00400000  *
0x26880E00  0x00000200  -
0x26881000  0x00800000  *
0x27081000  0x00000200  -
0x27081200  0x01000000  *
0x28081200  0x00000200  -

AND this is the end of  the log file

0x781D7926F3C600  0x40000000  *
0x781D7966F3C600  0x00000200  -
0x781D7966F3C800  0x40000000  *
0x781D79A6F3C800  0x00000200  -
0x781D79A6F3CA00  0x40000000  *
0x781D79E6F3CA00  0x00000200  -
0x781D79E6F3CC00  0x40000000  *
0x781D7A26F3CC00  0x00000200  -
0x781D7A26F3CE00  0x40000000  *
0x781D7A66F3CE00  0x7F87E285990C31FF  ?

The log file is 2gb in total.

The commands that i had run before that was

ddrescue -f /dev/sdd /dev/sdb /media/storage/1tb.log
Once that had finished i ran

ddrescue -d -f -r3 /dev/sdd /dev/sdb /media/storage/1tb.log

mkdir /dev/raw
cd /dev/raw
modprobe raw
raw /dev/raw/raw1 /dev/sdd
ddrescue -C -v -f -r3 /dev/raw/raw1 /dev/sdb /media/storage/1tb.log

That command was running fine until it got to it's last section where it only left a single section in the log file.

Did i do something wrong there? Or could this potentially be a bug?


Matthew Vukomanovic


Read this on how to become a computer expert: http://xkcd.com/627/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]