[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-ddrescue] ddrescue: Can't open input file: Permission denied

From: Robert Trevellyan
Subject: Re: [Bug-ddrescue] ddrescue: Can't open input file: Permission denied
Date: Tue, 6 Sep 2016 10:37:21 -0400

The error message refers to the input, not the log. Have you tried sudo?
sudo ddrescue -v -n /dev/sdb3 /dev/sdc1 /media/(user)/recoverylogfile.txt

Robert Trevellyan
518 392 0846

On Tue, Sep 6, 2016 at 9:11 AM, Kevin Okie <address@hidden> wrote:

> Dear All,
> I'm attempting to clone a corrutped Windows partition from bad
> disk/partition sdb3 to external HD device/partition sdc1
> The command I am using is:
> ddrescue -v -n /dev/sdb3 /dev/sdc1 /media/(user)/recoverylogfile.txt
> --force
> (doing '-n' at first to skip errors so i can return to them later)
> (added '--force' because without it I get the message "output file
> exists and is not a regular file". '--force' allows me to overwrite
> what is on the target device).
> Even if I shorten up the logfile part of the command to just
> 'logfile.txt' with no path, I get the same error. However, if I omit
> the logfile part of the command, the utility runs. However, I need the
> logfile to go back and try to recover parts of the drive with errors
> later.
> Any assistance much appreciated!
> Thanks!
> Kevin
> _______________________________________________
> Bug-ddrescue mailing list
> address@hidden
> https://lists.gnu.org/mailman/listinfo/bug-ddrescue

reply via email to

[Prev in Thread] Current Thread [Next in Thread]