[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: findutils -- updatedb hangs on solaris7

From: Alexander Tait Brotman
Subject: Re: findutils -- updatedb hangs on solaris7
Date: Thu, 20 Mar 2003 16:08:48 -0500 (EST)

I believe I have found the error.  It is NOT a bug with findutils.
Solaris has a directory called '/xfn'.  When this directory is accessed,
it halts the associated process.  So when updatedb tries to index /xfn, it
basically dies.  I have set it to prune /xfn.  Hopefully this will work.
Thanks for the help.

        ---Alex Brotman

On Thu, 20 Mar 2003, Stepan Kasal wrote:

> Hello,
>       tnak you very much for your bug report.
> On Wed, Mar 19, 2003 at 03:01:07PM -0500, Alexander Tait Brotman wrote:
> > `updatedb` hangs or never completes.  I basically tried just running
> > the program in the background (it also starts from cron).  But the program
> > never exits and the locatedb is never written.  It does create a locatedb.n
> > but it never seems to get a size.  I have tried pruning /proc/ and /dev/ 
> > with
> > the same results.  I can't really say its a bug in findutils, but any help
> > would be appreciated.  Thanks.
> be sure that when you pruned /proc and /dev, you include also the standard
> paths to prune:
> --prunepaths='/tmp /usr/tmp /var/tmp /afs /proc /dev'
> Perhaps you should experiment with smaller databases:
> --localpaths=/etc
> Maybe these experiments will show us something.
> Another path to follow is trying the latest development version:
>  It used to live at alpha.gnu.org, but currently is not available.
>  You can get it from:
>  ftp://ftp.du.se/pub/mirrors/sourceforge/murix/findutils-4.1.7.tar.bz2
> Good luck,
>       Stepan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]