[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #19605] find does not report symlink loop when trying to follow sym

From: Geoff Clare
Subject: [bug #19605] find does not report symlink loop when trying to follow symlinks
Date: Tue, 17 Apr 2007 09:28:06 +0000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv: Gecko/20070312 Firefox/

Follow-up Comment #5, bug #19605 (project findutils):

I take your point about d_type (the system I tried it on does have d_type). 
I still think that find should report this error.  With the -L option find
follows symlinks, so all the pathnames it writes to stdout should be files
that exist when symlinks are followed.  If "a" is a symlink loop it
effectively does not exist when symlinks are followed, because the pathname
does not resolve successfully.

Here is a slightly different case that may be more convincing:

$ ln -s a b
$ ln -s b a
$ find -L a/foo

Here find is reporting that a file called a/foo exists, which is obviously
not the case.

P.S. I have tried the patch, and I can confirm that it fixes the problem.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]