[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/2] find: add SELinux support

From: Kamil Dudka
Subject: Re: [PATCH 1/2] find: add SELinux support
Date: Mon, 20 Jul 2009 13:33:23 +0200
User-agent: KMail/1.11.4 (Linux/; KDE/4.2.4; x86_64; ; )

On Tue July 14 2009 21:31:22 Eric Blake wrote:
> Kamil Dudka <kdudka <at> redhat.com> writes:
> > In other words on Debian find does not change the working directory
> > before calling lgetxattr syscall. That's why lgetxattr does not see the
> > file and returns ENOENT (No such file or directory).
> One thing to look at would be kernel versions; not all kernels support
> openat and friends, so on older kernels, the fts traversal algorithms have
> to fake openat by using chdir, but on newer kernels, there are no chdir. 
> Meanwhile, it may be worth begging the kernel and glibc folks to consider
> implementing lgetxattrat and friends.

Sorry for confusion. My previous testing was completely wrong because I ran 
older version of findutils on Fedora. With the current git version it fails
on Fedora, too. It means something has been changed within findutils and/or 
gnulib in the meantime.

The attached incremental patch fixes it. Now it works on both Fedora and 
Debian. But unfortunately it does not work with the stable version (4.4.2)
of findutils. Could anybody point me to the relevant change in findutils
code? Thanks in advance!


Attachment: findutils-selinux-inc.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]