[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #47261] find produces two different results for the same command

From: anonymous
Subject: [bug #47261] find produces two different results for the same command
Date: Thu, 25 Feb 2016 19:24:55 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0


                 Summary: find produces two different results for the same
                 Project: findutils
            Submitted by: None
            Submitted on: Thu 25 Feb 2016 07:24:54 PM UTC
                Category: find
                Severity: 3 - Normal
              Item Group: Wrong result
                  Status: None
                 Privacy: Public
             Assigned to: None
         Originator Name: Len Schulwitz
        Originator Email: address@hidden
             Open/Closed: Open
         Discussion Lock: Any
                 Release: 4.4.2
           Fixed Release: None



On a Raspberry Pi B+ running Raspbian jessie, I run this command: "sudo find /
-iname 'firefox_binary.py'" to find a file I know exists.  The first time I
run it, find exits without any errors, and 0 results.  The second time I run
it, only seconds later, find locates the file.  Here is a video documenting
the behavior: youtube.com/watch?v=qDB_50RwWa8  In addition, I opened this up
as a question at
and it seems to have stumped all the unix gurus on there, who recommended that
I submit a bug report.  Here's the strace of the first run (fails):
http://lenschulwitz.com/find1.txt and the strace of the second run (succeeds):


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]