[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #57340] ekey goes into strange mode when reading shift-backspace

From: anonymous
Subject: [bug #57340] ekey goes into strange mode when reading shift-backspace
Date: Mon, 2 Dec 2019 17:47:40 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Follow-up Comment #3, bug #57340 (project gforth):

On one machine (Linux Mint 18) the output of ls -l
/etc/alternatives/x-terminal-emulator is:

lrwxrwxrwx 1 root root 31 Feb 16  2019 /etc/alternatives/x-terminal-emulator
-> /usr/bin/xfce4-terminal.wrapper

On another machine (Ubuntu submodule of Windows 10) it is:
lrwxrwxrwx 1 root root 15 Jun 1  2019 /etc/alternatives/x-terminal-emulator ->

To further test, I also used termux on android to access the linux mint PC. 
It also shows the same ekey effect. I can't tell you the
etc/alternatives/x-terminal-emulator, because termux doesn't have that.

Next I did a fresh install of gforth on an Ubuntu VPS installed on vultr.com
(using sudo apt-get install gforth).  Tried ekey with shift-backspace there --
same effect from both PCs as well as Android termux.  

I also accessed the VPS from a browser based terminal. However, that terminal
did not seem to allow shift-backspace.  shift-backspace registered in gforth
as just backspace.

Finally, I tried XTerm on Windows 10, connecting to the ubuntu LSM.  There,
keystrokes also don't show after ekey, but shift-backspace is captured as 27

Oh, I also tried xterm on the Mint 18 (Ubuntu xenial equiv), but same effect.


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]