[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: probs building TLS-enabled glibc-2.3.2 on RH 9 -- _errno undef

From: Gary Funck
Subject: RE: probs building TLS-enabled glibc-2.3.2 on RH 9 -- _errno undef
Date: Sat, 14 Aug 2004 16:19:01 -0700

> -----Original Message-----
> From: address@hidden
> [mailto:address@hidden Behalf Of Gary
> Funck
> Sent: Saturday, August 14, 2004 2:55 PM
> This build is on a Redhat 9 installation, running
> "gcc (GCC) 3.2.2 20030222 (Red Hat Linux 3.2.2-5)". I tried building glibc
> by downwloading both glibc-2.3.2.tar.gz and
> glibc-linuxthreads-2.3.2.tar.gz,
> unpacking, and the running configure as follows:
> /upc/glibc-2.3.2/src/configure --with-tls --enable-add-ons
> --prefix=/upc/glibc-2.3.2

Following up. I noticed in this glibc-3.4 bug note:
the following:

------- Additional Comments From jakub at redhat dot com  2004-08-10
17:25 -------
You should use --with-tls --without-__thread when building linuxthreads.
That's the switch combination which is tested and works, I doubt anybody
tested --with-tls --with-__thread linuxthreads in the last year or two.


I tried adding --withoug-__thread and the library builds without error.

I didn't see any instructions in the FAQ or elsewhere that mentioned this.
If --with-tls and __thread are so incompatible, it might be good if the
configure script issued a warning/error when those two options occur
together (or more accurately, when --with-tls is asserted, but
--without-__thread is not).

I'd still be interested in hearing about the recommended way is to build
glibc 2.3.2
so that it reproduces the same libc.so as is present on RH 9.0 (to the
extent possible).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]