[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: possible Global bug - not picking up symols?

From: jan
Subject: Re: possible Global bug - not picking up symols?
Date: Thu, 30 Apr 2020 11:42:52 +0100

I tried on linux as well. Ubuntu 19.10.
Other than the gpath/grtags/gtags files totalling 31.1MB, I get the
same result, both in symbols not found, and in the output of HTML from


On 30/04/2020, jan <address@hidden> wrote:
> (if anything below is unclear, please shout!  I will try to explain better)
> (also please acknowledge that it's been received, just so I know it's
> not got lost)
> Hi,
> this bug (if it is a bug) seems to have been around a long time. I can
> see a reference to something like this here, from 2007
> <https://lists.gnu.org/archive/html/bug-global/2007-10/msg00004.html>
> I installed Global yesterday, as part of setting up emacs as a proper
> IDE,  and started to play. I built the tag table and the very first
> thing I did was pick a random symbol and look for it.
> Global couldn't find it, which caused me a couple of hours more
> playing and reading the manual. I still don't get it. Maybe it's me.
> I am also very, very rusty with C++ so I may be getting things wrong there.
> The project is gromacs <http://www.gromacs.org/>.
> The size of the project source is 43.6MB. The total size of
> gpath/grtags/gtags is 17.4MB.  The documentation implies these would
> be about the size of the original source file, but this is ~1/3rd the
> size so I'm surprised.
> I looked for a constructor
> "AnalysisDataPointSetRef::AnalysisDataPointSetRef". It can't find this
> or even "AnalysisDataPointSetRef" by itself. It can't seem to find a
> number of symbols.
> If I generate the HTML it
> AnalysisDataPointSetRef::AnalysisDataPointSetRef shows up, but without
> underlining. In fact quite a number of symbols show up without
> underlining in that source file. The following is from the HTML file
> with recognised (underlined) items made upper case.
> AnalysisDataFrameHeader::AnalysisDataFrameHeader
>  (int index, REAL X_, REAL dx) :
>     index_(index),
>     X_(x),
>     DX_(dx)
> {
>     GMX_ASSERT(index >= 0, "Invalid frame index");
> }
> Non underlined items are
> AnalysisDataFrameHeader::AnalysisDataFrameHeader, index_, index, x and
> dx. Therefore it seems not to be picking these up?
> Looking for these it can find the underlined ones:
>>>>global dx_
> gromacs_working/src/gromacs/analysisdata/dataframe.cpp
> but
>>>>global index
> (nothing)
> From the same file, another example; similar constructor but
> conventional parameters are being inconsistenly picked up. As before
> underlined items are made upper case here:
> AnalysisDataPointSetRef::AnalysisDataPointSetRef
>                       (const AnalysisDataFrameHeader&  HEADER,
>                   const AnalysisDataPointSetInfo& pointSetInfo,
>                   const ANALYSISDATAVALUESREF&    values)
> So it can see HEADER and ANALYSISDATAVALUESREF but apparently nothing else?
> OS is windows 2008R2.
> Global version is 6.6.3
> The project compiles cleanly so it's not been confused by syntax errors.
> Happy to help further.
> thanks
> jan

reply via email to

[Prev in Thread] Current Thread [Next in Thread]