[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gmp 4.0.1 - Can't install correctly

From: Kevin Ryde
Subject: Re: gmp 4.0.1 - Can't install correctly
Date: Thu, 16 May 2002 08:36:33 +1000
User-agent: Gnus/5.090006 (Oort Gnus v0.06) Emacs/21.1 (i386-debian-linux-gnu)

enzo criscione <address@hidden> writes:
>          If we try to include 'gmp.h' in any program, the program
> compiles and links but
>          does a segmentation fault right away, even if no function is
> used from gmp.

That sounds very strange, it's hard to think what gmp.h alone could do
to upset anything.  Does a trivial "hello world" program work?

>         Compiler is GCC 2.96

Hmm.  That was a dodgy intermediate snapshot wasn't it?  You might be
better off with 2.95 or 3.0.

> FAIL: t-constants
> FAIL: t-count_zeros
> FAIL: t-gmpmax
> FAIL: t-modlinv

These are all pretty simple, so it sounds like there's something
fairly fundamental going wrong.  They all should print something if
they fail too.  You could try running up the debugger with for

        cd tests
        ../libtool gdb t-constants

reply via email to

[Prev in Thread] Current Thread [Next in Thread]